Monitoring and Editing Processes

In addition to building process models, the Appian process modeler can also be used to monitor the execution of process instances, test your process models, and edit active process instances. This page will walk through the different ways you can interact with process instances from the modeler.

  • See the Monitoring view page for detailed reference information about monitoring the process activity on your system in Appian Designer.
  • For guidance on identifying and fixing common process issues, see Troubleshooting Process Models.
  • For more details on the types of process errors that you could encounter, see the Process Errors reference page.

Interpreting Process Flows

Each process flow is composed of flow objects. A flow object is any object that can be added to the sequence flow of a process model in the Process Modeler, including flow connectors, activities, gateways, and so on.

When in Monitor mode or Edit mode, the process flow objects display with different colored borders, depending on their status.

  • Blue: Completed flows and flow objects. (See the Start Event object below.)
  • Green - Active flow objects. (See the Participation object below.)
  • Red - Paused flow objects.
  • Red with a slash (Ø) through the object - Flow objects that are canceled by exception.
  • No color - Flow objects that are not yet activated by the sequence flow. (See the Script Task object below.)

Process Flow

When viewing process models with exception flows, all exception flows appear in red before they have been executed. Upon execution, the flow color changes to purple as shown below:

Exception Flow

When a node is skipped due to an exception flow, it appears shaded with diagonal lines. This is shown in the Team Information node above.

Monitor Mode

While viewing a process instance in Monitor mode, you can monitor and administer active flow objects.

Viewing a Process in Monitor Mode

To access Monitor mode for a process instance:

  1. Navigate to the Monitoring view in Appian Designer or an application view.
  2. Locate the process instance that you want to monitor.
  3. Click on the Name link.
  4. The process instance opens in Monitor mode in the Process Modeler. The current status of the flow objects are displayed.

If you want to make updates to the process instance's process model as a result of what you've found in Monitor mode, follow the instructions in the Navigation in the Process Modeler section to open the model while viewing the process.

In Monitor mode, the Process Modeler displays a different set of toolbar options.

Pausing a Process

To pause a process instance, select Modify > Pause from the toolbar.

When an instance is paused, the following occurs:

Tasks

  • Active tasks assigned to a user no longer show up in the user's Tasks list.
  • Task show up with the "Paused" status in the All Tasks report.
  • Tasks submitted while the process instance is paused display an error upon submission.
  • Users cannot save tasks related to the process instance. If a user is actively working on a task when a process instance is paused, the user will not be able to save or submit the task. If the process instance resumes before the user clicks on either save or submit, the user can successfully submit the task.

Message Events

  • Active receive message event nodes will not receive any messages while the process instance is paused, and the messages will not be queued.
  • Messages sent after the process instance resumes will be received.

Timer Events and Active Nodes

  • Active timer events and active nodes scheduled to execute while the process instance is paused only execute when the instance is resumed.
  • Active timer event nodes and active nodes configured to recur at a certain interval continue to generate new instances of the activity while the process instance is paused. The instances only execute when the process instance is no longer paused.
    • For example, if you pause a process for 10 minutes, and a node is configured to repeat every 1 minute, if the node is an unattended smart service, the smart service runs 10 times when the process is resumed.
    • If the node is an unattended script task that stores a value into a process variable, the value is written to the process variable 10 times when the process resumes.

Synchronous Sub-processes

  • Active synchronous sub-process nodes with Output Variable mappings write values from the sub-process to the parent process while the parent process is paused.
  • Any sub-processes do not pause with the parent process.
  • The output flow from the sub-process node will only be taken when the process resumes.
  • When the output flow of a sub-process node is configured to "keep process variables synchronized across this flow", the synchronization is preserved after the parent process resumes.

Resuming a Paused Process

To resume a process instance, select Modify > Resume from the toolbar.

Changing Process Variables

It's possible to change the value of process variables in a process instance. The approach differs based on the type of the variable.

To change process variables of system data types:

  1. From the toolbar, select the Process Model Properties icon to view the process variables.
  2. Select a process variable to update it.
  3. For a process variable of type multiple, insert the value with a comma separator. For example, to add an array of two values to a process variable of type Text, enter text string 1, text string 2.

To change process variables of custom data types, you need to add a script task to your process model that stores the new value into the variable:

  1. Edit the process.
  2. Drag and drop a script task onto the canvas.
  3. Add a node input, and choose the custom data type as its type.
  4. Set the new values.
  5. Save the node input into the process variable that you want to update.
  6. Apply your changes to the process instance.
  7. Switch to Monitor mode.
  8. Close the tab open in Edit mode.
  9. Right-click on the new script task and select Start.

To change an encrypted text value, you can use a technique similar to modifying values of custom data types:

  1. Edit the process.
  2. Drag and drop a User Input task onto the canvas.
  3. Add a node input of type Encrypted Text.
  4. Configure an interface that displays the encrypted text value and saves the updated value back into the node input.
  5. Save the node input into the process variable that you want to update.
  6. Apply your changes to the process instance.
  7. Switch to Monitor mode.
  8. Close the tab open in Edit mode.
  9. Right-click on the new User Input task and select Start.

Updating a Flow Object in Monitor Mode

A designer has the following options for flow objects when monitoring a process instance.

Pause a Flow Object

To pause a flow object, right-click an active node (indicated by a green border) and select Pause. The border of the paused node will become red.

When a node within a process instance is paused, the instance is still active. There can be more than one active flow in a instance. When a flow reaches a node that is paused, and there is only one active flow in the instance, the entire process instance is paused. The node must be resumed for the instance to continue.

Start a Flow Object

To start a new instance of a node, right-click the object and select Start.

Follow the same steps to resume an activity that was canceled by exception.

View Activated Instances

To view activated instances of a node, right-click the activity in Monitor mode to see an indicator of how many instances there are.

Number of Instances

Select Instances to display the Spawned Nodes dialog box, which lists details about each activated instance.

Spawned Nodes

The following actions are available for a selected object instance, depending on its status:

  • View Node Details
    • Opens the Properties dialog box, which allows a designer to view errors and change task properties, including the assignee, priority, deadline, and escalation settings.
      • When changing the assignment, the Reassign Automatically option removes the current assignment and send the task back to all original assignees. This option is mainly used for tasks that were originally assigned to a group.
      • When setting a new deadline, a future date must be selected. To remove an existing task deadline, clear the Set deadline checkbox.
      • Existing escalations can be skipped or triggered. Skipped escalations are canceled. Triggered escalations are executed immediately, using the configured settings.
  • Pause
    • Allows a designer to pause an active instance.
  • Resume
    • Allows a designer to resume a paused instance.
  • Cancel
    • Allows a designer to cancel active and paused instances or instances with errors.
    • Once a quick task has been activated, it can be disabled or canceled by canceling all the active instances.
  • Trigger Schedule
    • Allows a designer to trigger the selected node immediately, if it's scheduled to start at a specific time.

After making changes, click Close to exit the dialog.

View and Complete a Form

To view and complete a form, right click a flow object and select View Form to display the form. Users with the right to do so can complete the form.

Edit Mode

While viewing a process instance in Edit mode, you can make structural and configuration changes to the sequence flow in an active instance.

Viewing a Process in Edit Mode

To access Edit mode for a process instance:

  1. Navigate to the Monitoring view in Appian Designer or an application view.
  2. Locate the process instance that you want to monitor.
  3. Click on the Name link.
  4. The process instance opens in Monitor mode in the Process Modeler. The current status of the flow objects are displayed.
  5. Click the dropdown in the top right of the Process Modeler and select Edit Process View.
  6. The process instance opens in Edit mode in a new tab of the Process Modeler.

In Edit mode, the Process Modeler displays a different set of toolbar options.

Editing a Running Process

When you open a running process for editing, it pauses the process.

If there are multiple process instances at different steps, the following rules apply:

  • Instances are affected by changes to rules or other node changes once they reach the process step that corresponds with the node where the changes were made.
  • If you change the rules for a particular node, users who have already completed the corresponding process action are not affected. Only instances that have not yet reached the updated step are affected by the new rules.
  • Additional nodes and connectors can be added and business rules can be changed to send instances down a new process flow. Such changes are often best configured using an Exception flow.
  • Activating a timer event locks in a schedule for that event, which cannot be changed in an active process flow. You must delete and recreate the event to apply new timer settings.
  • To save the selected process instance as a new version, you must have the right to save changes in the Process Model Folder where the process model is stored. This is in addition to having administrator level access to an instance, and editor level access to the process model.

Two users cannot make changes to the same process instance at the same time; however, multiple users can edit different running instances of the same process model.

  • Depending on the security rights of the user, if a user attempts to change a process instance that is being edited, a message is displayed asking them whether they want to edit the instance anyway. If they choose to proceed, the first editor of the instance is prevented from making further edits. The new user can then make changes.
  • If the new user decides not to proceed with editing, the process instance opens in the Process Modeler in read-only mode.

Saving Changes

Once you have made the desired changes, they can be applied to the process instance or saved to the process model. Both options are available under the File menu:

  • Apply Changes Changes are only applied to this particular instance of the process. They are not saved for later use. Future executions of the process will not reflect the changes made.
  • Save New Version Changes are saved as a minor version update to the latest published version of the process model. Minor version updates must be published before they appear in new instances of the process model. The changes are also applied to this particular instance of the process.

Once a process instance is modified, it is validated. Any validation errors are displayed on the Modeler interface. Validation errors must be resolved before changes can be applied to the instance or process model successfully.

Debug Mode

To iteratively develop and test your process models, you can debug a process instance directly within the process modeler.

Running a process in debug mode starts the process and performs the configured actions in the same manner as if it were started by a user. Any emails or alerts that you configure will be sent to the specified users. The process instance is opened in monitor mode.

To avoid any problems when debugging your process model, make sure to Save & Publish it before selecting Start Process for Debugging.

If your process model uses a start form, it will launch the latest published version of your process model, but use the start form from its latest draft.

If your process model doesn't have a start form, process modeler will launch the latest draft when you Start Process for Debugging.

Running Your Process in Debug Mode

  • With the process open in the Process Modeler, click File > Save & Publish.
  • Click File > Start Process for Debugging.
  • For each attended node, right-click the node and select View Task Form.
  • Complete the form and click Submit. Any errors are displayed. If your forms are Activity-Chained, the subsequent form is displayed. If the Activity-Chain enters a Sub-Process node, the sub-process opens in a new tab.
  • View the task form for each attended node in your process.

Viewing Process Errors in the Process Modeler

While viewing a process instance in the modeler, you can view error messages for any problems that have occurred in the process to assist in debugging.

There are two ways to view the errors that have occurred in a process while in the modeler:

  1. Viewing the properties dialog of a node will display the error message of any node that encountered an error. If the node was executed multiple times, you can drill down to the error message of an individual instance by right-clicking on the node, selecting the Instances option, and then finding the appropriate instance in the Spawned Nodes dialog. images:node_error_in_modeler.png

  2. The Process Details dialog includes a tab called Errors. This view will show any unresolved errors that have occurred in the process. You can also select the View resolved errors option to see a history of every error that has occurred in the process instance. images:process_details_error_dialog.png

Viewing Process Details

Once a process is started, Process Details are available to users with appropriate privileges when monitoring or editing the process instance.

The Process Details dialog serves as an administrative tool for process owners and other actors, who can use it to perform actions that affect the flow of a process. The actions that can be performed through this interface vary according to the security settings a user has for the corresponding process.

  1. Select the Monitoring tab in Appian Designer or in the application view. Recent processes are listed.
  2. Click a process to open it in Monitor mode.
  3. When viewing the process in the modeleler, click the Process Details button in the toolbar. The process details dialog opens, with the tabs described below.

images:process_details_highlight.png

Process History

The Process History tab allows you to view executed actions associated with the process, as well as the changes made by the process.

  • Process history data includes the following information:
    • The date and time of the action
    • The process object that caused the action
    • The action that took place (or that is occurring), for example: Start, Complete, Retry.
    • The actor (or user account) whose credentials were used to perform the action
    • The properties of the action taken, including the process variable values written by an action
  • The table used to display this information is sorted by the Date & Time column in descending order (most recent action is listed on top). You can sort the table by any of the column headers.

For changes to process variables that hold multiple values (or multiple items in a custom data type), only the first 100 items are retained in process history.

Process Variables

The Variables tab allows you to view and update process variables in the active process instance.

Each process variable is listed, along with its data type, multiplicity, and current value. To edit a process variable, click the Edit link for the process variable.

Note: If this link does not appear, you do not have sufficient user rights to edit the variable.

After clicking the link, the Edit Process Variable dialog box is displayed. You can directly update the process variable value from here. Changes are immediately reflected in the process instance.

Updating Complex Data Type and Encrypted Text Variables

You cannot directly edit process variables that are complex data types or Encrypted Text.

In order to modify the value of a complex data type in a running process, you need to add a script task to your process model that stores the new value into the variable. To do this, use the Edit Process feature.

It is not possible to change an encrypted text value to another encrypted text value from the Process Details dialog. Instead, you can use a similar technique as the one described above for modifying values of complex data types. To do this, use the Edit Process feature to add a User Input task with a SAIL form that displays the encrypted text value and saves the updated value back into the process variable.

Process Nodes

The Process Nodes tab lists each node in a process. If an activity is executed multiple times, then multiple entries are listed for that activity.

By default, this list does not include nodes associated with any sub-processes. You can view the subprocess nodes by selecting the Show nodes from sub-process checkbox. These nodes can be distinguished by the Process ID and Process Name columns. All nodes from a subprocess will have different IDs and names than nodes that reside in the parent process.

Note: When this checkbox is selected, nodes from nested sub-processes are also displayed. Up to 10 levels of nested nodes are displayed.

Each of the nodes is listed in a table that displays the following columns:

  • Node Name
  • Status
  • Owner
  • Priority
  • Time: when the node was started
  • Duration: how much time was spent during node execution
  • Process ID: The local ID of the process associated with the node.
  • Process Name: The name of the process associated with the node.

Each node listed on this tab has additional actions available to Managers, Editors, and Administrators of the process. Selecting the checkbox associated with a node displays the actions that are available to the user.

The following options are only available to Process Administrators, System Administrators, and the Administrator account:

  • Start
  • Pause (only applies to active nodes)
  • Cancel (only applies to active nodes)

Current Tasks

The Current Tasks tab displays all active tasks for the process. To view or complete a task that you have permissions to, click the task name. Depending on permissions, you can also reassign or cancel a task from this tab by selecting the checkbox next to it.

Errors

The Errors tab displays all active errors for the given process. Each of the errors is listed in a table that displays the following columns:

  • Node Instance
  • Error
  • Occurred date and time

By default, this list does not include resolved errors and errors associated with any sub-processes. You can view the resolved errors by selecting the Show resolved errors checkbox.

See also: Process Errors

Sub-Processes

The Sub-Processes tab displays all sub-processes that have been triggered by the given process are displayed. Clicking on a sub-process will open the sub-process in Monitor mode.

See also: Sub-Process

Quick Tasks

The Quick Tasks tab displays all of the quick tasks that have been activated by the current process. The grid lists the task name, the date and time at which the task was enabled, and the users who have the right to view and complete the quick task.

By default, the tasks displayed within the grid are sorted by Task Name in descending order. You can sort the table by any of the column headers.

To view or complete a quick task, click the task name. After submission of a quick task, a new task instance is automatically generated and listed on the tab.

See also: Creating a Quick Task

When viewing a process instance in the Process Modeler, you can easily navigate to the process instance's parent instance and its process model or switch between the different modes.

To navigate to the process instance's parent process:

  1. Open the File menu.
  2. Click Open Parent Process.
  3. The process instance's parent will open in a new tab in the Process Modeler in Monitor mode.

To navigate to the process instance's process model:

  1. Open the File menu.
  2. Click Open Process Model.
  3. The process instance's process model will open in a new tab in the Process Modeler.

To switch between Monitor mode and Edit mode:

  1. Click the dropdown in the top right of the Process Modeler.
  2. Select the mode to switch to, either Monitor or Edit.
  3. The process instance opens in the selected mode in a new tab of the Process Modeler.

Once you have completed monitoring or editing a process instance, you can exit the Process Modeler by clicking x on the top-right corner of the tab.

FEEDBACK