Testing Process Models

Debug Mode

To iteratively develop and test your process, you can debug a process instance directly within the Process Modeler. The progress of your process can be visually monitored and all task forms are available for viewing and submission. This feature is best used in a dedicated development environment.

Running a process in debug mode starts the process and performs the configured actions in the same manner as if it were started by a user. Any emails or alerts that you configure will be sent to the specified users.

To avoid any problems when debugging your process model, make sure to Save & Publish it prior to selecting Start Process for Debugging.

If your process model uses a SAIL start form, it will launch the latest published version of your process model, but use the SAIL start form from its latest draft.

If your process model doesn't have a SAIL start form, process modeler will launch the latest draft when you Start Process for Debugging.

Running Your Process in Debug Mode

  • With the process open in the Process Modeler, click File > Save & Publish.
  • Click File > Start Process for Debugging.
  • For each attended node, right-click the node and select View Task Form.
  • Complete the form and click Submit. Any errors are displayed. If your forms are Activity-Chained, the subsequent form is displayed. If the Activity-Chain enters a Sub-Process node, the sub-process opens in a new tab.
  • View the task form for each attended node in your process.

Changing Your Process Model in Debug Mode

  • From the Debug view, select Edit Mode from the toolbar. The Process Model opens in a new tab.
  • Edit your Process Model.
  • When you are finished editing, click File > Apply Changes.
  • Close the Edit Mode tab. The Monitor Mode tab remains and is refreshed with your updated process.

Analyzing Performance

You can evaluate the design performance of your process model by displaying a historical execution report that is overlaid on the process model.

When editing a process model, it is often useful to view metrics on past performance of each node in the process model. Similarly, when making run-time changes to an active process, it can also be useful to view useful metrics about the performance of the process and the underlying process model as a whole. These metrics can often serve as barometers when it comes to identifying bottlenecks in a process model and can be used to fine tune a process model for optimal performance.

Two reports are used to generate metrics that can be displayed in the process modeler.

  1. Default Process Model Optimization Metrics
  2. Default Process Optimization Metrics

These reports can be opened in the Application Designer.

  • Click the Reports tab.
  • In the left navigation (or main window navigation, select the Process Optimization Reports folder.
  • Select the report that you want to view or edit.

Editing Process Optimization Reports

Default Process Model Optimization Metrics
  • Select this report. The Select a Process Model dialog box is displayed, which lists the process model folders, that you can view.
  • Select a process model. Click OK. All columns configured for this report can be displayed as metrics within the process modeler. By default, this report includes three columns of data.
  1. Name
  2. Avg Lag
  3. Avg Completion
Default Process Optimization Metrics
  • Select this report. The Select a Process dialog box is displayed, which lists the processes that have been started in the system that you can view. Click OK. All columns configured for this report, along with the columns configured for the Default Process Model Optimization Metrics report, can be viewed as metrics within the process modeler. By default, this report displays three columns of data.
  1. Name
  2. Actual Lag
  3. Actual Completion

To configure either of these reports, click the Edit toolbar button. The Report Options wizard is displayed. From this wizard, existing data can be edited, and new columns can be added.

See also: Editing a Report.

Once changes have been made to the report, click the save button on the toolbar to apply your changes. (Only system administrators can save the report. Saving a report template results in the change being applied system wide. Any changes are applied for all users who access the report template.)

The data displayed within the report is grouped by the Node Name. Therefore, if two activities have the same name the same data is displayed for both objects.

Viewing Lag and Completion Times in the Process Modeler

To view metrics in the process modeler:

  • Open a process model.
  • Click the View Metrics button on the toolbar. — or —
  • Select View > Show Node Metrics.


When viewing a process model, all columns configured through the Default Process Model Optimization Metrics report appear as a metric for each node in the process model. When editing a running process, all columns configured for both the Default Process Model Optimization Metrics and the Default Process Optimization Metrics reports are displayed as metrics for each node in the process. A maximum of 20 metrics can be displayed for a node on the designer canvas. Therefore, if there are more than 20 columns configured, only the first 20 columns appear in the modeler.


All columns configured in the report are displayed in the same order in which they appear in the report. Each column of data is aggregated. If no data is available for a particular metric, n/a appears next to the metric for the given node. All formatting applied to the data in the report is preserved when it is displayed as metric in the process modeler.

FEEDBACK